HEVC-MP4 verbinden

  • Autor
  • Nachricht

dino

Offline



  • Wohnort: Berlin
1  Do Feb 01, 2018 8:44
Guten Morgen,

kennt jemand vielleicht eine Methode oder eine (günstige) Software, um auf dem Mac zwei in H.265 (HEVC) 10 bit in MP4-Containern kodierte Videos zu verbinden, ohne diese neu zu kodieren?

Hintergrund: Mein DVB2-HD-Receiverver legt Aufnahmen in ca. 1Gb-großen TS-Dateien ab. Ich habe diese mit Handbreak zu besagten MP4s gemacht, die der Mac nativ abspielen können soll. Allerdings sind es immer noch einzelne Dateien, da Handbreak diese nicht verbindet. VLC, das die Dateien hervoragend abspielt, soll das wohl auch können, ich habe aber noch nicht rausfinden können wie.

Gruß Dino

MacJoerg

Offline

Benutzeravatar



  • Wohnort: Rottenburg a.N.
2  Do Feb 01, 2018 12:28
Versuch es mal damit. Ich benutze das Progrämmchen schon lange zum "zusammenkleben". :D
Funktionierte bei meinen mp4-Dateien prima.
https://www.mp4joiner.org/de/
Gruß, Jörg

dino

Offline



  • Wohnort: Berlin
3  Do Feb 01, 2018 12:52
Hallo Jörg,

den habe ich auch schon länger im Einsatz, ich bekomme damit aber keine h.265 kodierten MP4s bearbeitet. Hast du das mal versucht? Aber genau so ein Tool suche ich oder einen Terminalbefehl, der das kann.

Gruß Dino

MacJoerg

Offline

Benutzeravatar



  • Wohnort: Rottenburg a.N.
4  Do Feb 01, 2018 13:46
Ne Du. h265 hab ich wohl nicht. Ist auch schon eine Weile her dass ich das gebraucht hab.
Audiodateien hab ich mit dem Terminal schon mal zusammengefügt. Aber wie das genau ging weiss ich leider nicht mehr.
Gruß, Jörg

lamariposa

Offline



  • Wohnort: bei Hamburg
5  Do Feb 01, 2018 16:40
dino hat geschrieben:…zwei in H.265 (HEVC) 10 bit in MP4-Containern kodierte Videos zu verbinden, ohne diese neu zu kodieren?…

Der Quicktime Player X kann das nicht zufällig? So wie hier beschrieben (weiter unten unter „Ausschneiden, Kopieren, Einsetzen und Löschen“):
https://support.apple.com/de-de/HT201066
Ist ein älteres Support-Dokument, bezieht sich also nicht auf das neue Format. Aber vielleicht hält Apple den Player ja aktuell, dann könnte es unter High Sierra gehen. Habe ich jedoch nicht, ist also nur ins Blaue geraten…

polysom

Online

Benutzeravatar


  • Wohnort: Dresden
6  Do Feb 01, 2018 20:18
Wenns auch per Terminal geht, kannst du das mit ffmpeg machen. Das ist das Schweizer Messer wenn es um Video/Audio geht. :grin:
https://trac.ffmpeg.org/wiki/Concatenate
Bild
Solange Kakaobohnen an Bäumen wachsen, ist Schokolade für mich Obst.
Homepage - Securebird - Soundcloud - Mixcloud

dino

Offline



  • Wohnort: Berlin
7  Fr Feb 02, 2018 21:02
lamariposa hat geschrieben:
dino hat geschrieben:…zwei in H.265 (HEVC) 10 bit in MP4-Containern kodierte Videos zu verbinden, ohne diese neu zu kodieren?…

Der Quicktime Player X kann das nicht zufällig?

Nee, leider nicht! Habe ich ausprobiert und brachte eine Fehlermeldung.

dino

Offline



  • Wohnort: Berlin
8  Fr Feb 02, 2018 21:06
polysom hat geschrieben:Wenns auch per Terminal geht, kannst du das mit ffmpeg machen. Das ist das Schweizer Messer wenn es um Video/Audio geht. :grin:
https://trac.ffmpeg.org/wiki/Concatenate

Terminal und ffmpeg gehen, wenn ich eine geeignete Vorlage finde. Hast du da zufällig etwas, polysom? Ich habe nur Beispiele zu h.264 gefunden und da da noch kryptische Zahlenkolonnen bei sind, die ich noch nicht durchschaue (Auflösungen? Seitenverhältnisse? Codexnummern??), hab ich noch keinen rechten Zugang. Ich suche da mal weiter und bin dankbar für Tipps!

Gruß Dino

polysom

Online

Benutzeravatar


  • Wohnort: Dresden
9  Fr Feb 02, 2018 21:53
Ich hab das nicht getestet, aber das hier sollte funktionieren, wenn der Codec bei allen Videos identisch ist:
Code: Alles auswählen
$ ffmpeg -i "concat:input1.mp4|input2.mp4|input3.mp4" -c copy output.mp4


Anstatt input1 usw. musst du halt den Pfad zu deiner Videodateien einsetzten und statt Output, da wo das Video hin soll. Also angenommen die drei Videostücke liegen in deinem Videoordner und sollen da auch hin:


Code: Alles auswählen
$ ffmpeg -i "concat:/Users/dino/Movies/input1.mp4|/Users/dino/Movies/input2.mp4|/Users/dino/Movies/input3.mp4" -c copy /Users/dino/Movies/output.mp4
Bild
Solange Kakaobohnen an Bäumen wachsen, ist Schokolade für mich Obst.
Homepage - Securebird - Soundcloud - Mixcloud

dino

Offline



  • Wohnort: Berlin
10  Sa Feb 03, 2018 12:26
Danke, polysom, hört sich einfacher an, als ich bislang gelesen hatte. Ich probier das am WE mal aus und berichte!

Gruß Dino

Rotweinfreund

Online

Benutzeravatar


  • Wohnort: Vier-Tore-Stadt
11  Sa Feb 03, 2018 13:13
polysom hat geschrieben:Anstatt input1 usw. musst du halt den Pfad zu deiner Videodateien einsetzten
es sollte etwas bequemer werden, wenn man die entsprechenden Dateien an jener Stelle ins Terminalfenster zöge … hoffe ich zumindest, dass dieses Prinzip auch bei diesem Befehl funktioniert.

polysom

Online

Benutzeravatar


  • Wohnort: Dresden
12  Sa Feb 03, 2018 13:29
Rotweinfreund hat geschrieben:
polysom hat geschrieben:Anstatt input1 usw. musst du halt den Pfad zu deiner Videodateien einsetzten
es sollte etwas bequemer werden, wenn man die entsprechenden Dateien an jener Stelle ins Terminalfenster zöge … hoffe ich zumindest, dass dieses Prinzip auch bei diesem Befehl funktioniert.


Ja das geht, so mache ich das auch immer.
Bild
Solange Kakaobohnen an Bäumen wachsen, ist Schokolade für mich Obst.
Homepage - Securebird - Soundcloud - Mixcloud

dino

Offline



  • Wohnort: Berlin
13  Sa Feb 03, 2018 15:42
Klappt leider noch nicht. Das Terminal meldet "-bash: $: command not found". Scheint schon am Anfang ein Problem zu haben. Muss der User, der das macht, irgendwelche Rechte haben?

mac-christian

Offline

Benutzeravatar


  • Wohnort: Helvetien
14  Sa Feb 03, 2018 16:42
dino hat geschrieben:Klappt leider noch nicht. Das Terminal meldet "-bash: $: command not found". Scheint schon am Anfang ein Problem zu haben. Muss der User, der das macht, irgendwelche Rechte haben?

Das $-Zeichen ist der Prompt des Terminals. Den solltest du nicht hinschreiben, weil es $ als Befehl nicht gibt.
Dateianhänge

dino

Offline



  • Wohnort: Berlin
15  Sa Feb 03, 2018 16:56
Okay, ich habe das prompt weggelassen und für die ffmpeg-app den Pfad ergänzt. Jetzt sieht das Ganze so aus:

1.mp4 | /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_2.mp4" -c copy /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_gesamt.mp4
ffmpeg version 3.4.1-tessus Copyright (c) 2000-2017 the FFmpeg developers
built with Apple LLVM version 8.0.0 (clang-800.0.42.1)
configuration: --cc=/usr/bin/clang --prefix=/opt/ffmpeg --extra-version=tessus --enable-avisynth --enable-fontconfig --enable-gpl --enable-libass --enable-libbluray --enable-libfreetype --enable-libgsm --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-libzmq --enable-libzvbi --enable-version3 --pkg-config-flags=--static --disable-ffplay
libavutil 55. 78.100 / 55. 78.100
libavcodec 57.107.100 / 57.107.100
libavformat 57. 83.100 / 57. 83.100
libavdevice 57. 10.100 / 57. 10.100
libavfilter 6.107.100 / 6.107.100
libswscale 4. 8.100 / 4. 8.100
libswresample 2. 9.100 / 2. 9.100
libpostproc 54. 7.100 / 54. 7.100
concat:/Volumes/MusicAndMovies/AppleTV-Filme/Lucy_1.mp4 | /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_2.mp4: No such file or directory

Die beiden Inputs habe ich nach RWFs Tipp mit drag und drop eingesetzt. Woran kann es jetzt liegen?

Danke für die Hilfe an alle!

Gruß Dino

Rotweinfreund

Online

Benutzeravatar


  • Wohnort: Vier-Tore-Stadt
16  Sa Feb 03, 2018 18:40
8)
concat:/Volumes/MusicAndMovies/AppleTV-Filme/Lucy_1.mp4 | /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_2.mp4:
De Filme Lucy_1 und Lucy_2 liegen also auf einem Volumen, welches MusicAndMovies heisst?

Ich denke eher, dass du die Syntax noch nicht richtig eingehalten hast.

dino

Offline



  • Wohnort: Berlin
17  Sa Feb 03, 2018 18:49
Rotweinfreund hat geschrieben:8)
concat:/Volumes/MusicAndMovies/AppleTV-Filme/Lucy_1.mp4 | /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_2.mp4:
De Filme Lucy_1 und Lucy_2 liegen also auf einem Volumen, welches MusicAndMovies heisst?

So ist es. Wie wäre denn dann die Syntax?

Rotweinfreund

Online

Benutzeravatar


  • Wohnort: Vier-Tore-Stadt
18  Sa Feb 03, 2018 19:04
Puh, habe ja auch keine große Ahnung. Deshalb halte ich mich mal zurück.
Habe leider jetzt auch nix Vergleichbares zum Testen.

dino

Offline



  • Wohnort: Berlin
19  Sa Feb 03, 2018 20:23
Oh, die erste Zeile in meinem Befehl fehlt! Der ganze Befehl hieß:
/Applications/Video/ffmpeg -i "concat:/Volumes/MusicAndMovies/AppleTV-Filme/Lucy_1.mp4 | /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_2.mp4" -c copy /Volumes/MusicAndMovies/AppleTV-Filme/Lucy_gesamt.mp4
Nur zur Klarstellung. Hat jemand eine Idee?

Macci

Offline

Benutzeravatar

Moderator




  • Wohnort: Leibzsch
20  Sa Feb 03, 2018 20:33
Da sind mehr Leerzeichen drin, als in polysoms zweitem Beispiel. Also zwischen | und / zum Beispiel.

mac-christian

Offline

Benutzeravatar


  • Wohnort: Helvetien
21  Sa Feb 03, 2018 20:38
Möglicherweise ein Vertipper in einem der Dateipfade.

Versuche doch einfach folgendes:

Schreib hin: /Applications/Video/ffmpeg -i "concat:

und dann ziehst du den ersten Teil des Films von der Platte ins Terminalfenster; dann schreibst du | und dann ziehst du den zweiten Teil des Films von der Platte ins Terminalfenster. Das " am Ende anfügen und dann ziehst du den Ordner, in dem du das Ergebnis haben willst ins Terminalfenster und schreibst noch den gewünschten Dateinamen dahinter. Dann die Entertaste.

So schliesst du Vertipper aus - aber ob die Syntax stimmt, kann ich dir nicht sagen...

dino

Offline



  • Wohnort: Berlin
22  Sa Feb 03, 2018 21:33
Macci hat geschrieben:Da sind mehr Leerzeichen drin, als in polysoms zweitem Beispiel. Also zwischen | und / zum Beispiel.

Eigentlich sollte das immer genau eines sein. Prüfe ich aber noch einmal.

dino

Offline



  • Wohnort: Berlin
23  Sa Feb 03, 2018 21:35
mac-christian hat geschrieben:Möglicherweise ein Vertipper in einem der Dateipfade.

Versuche doch einfach folgendes:

Schreib hin: /Applications/Video/ffmpeg -i "concat:

und dann ziehst du den ersten Teil des Films von der Platte ins Terminalfenster; dann schreibst du | und dann ziehst du den zweiten Teil des Films von der Platte ins Terminalfenster. Das " am Ende anfügen und dann ziehst du den Ordner, in dem du das Ergebnis haben willst ins Terminalfenster und schreibst noch den gewünschten Dateinamen dahinter. Dann die Entertaste.

So schliesst du Vertipper aus - aber ob die Syntax stimmt, kann ich dir nicht sagen...

Hallo Christian,
exakt auf diese Weise hab ich es gemacht! Aber Fehler können natürlich trotzdem passieren, ich kann nur leider nicht erkennen, wo. :(

lamariposa

Offline



  • Wohnort: bei Hamburg
24  So Feb 04, 2018 0:00
dino hat geschrieben:
Macci hat geschrieben:Da sind mehr Leerzeichen drin, als in polysoms zweitem Beispiel. Also zwischen | und / zum Beispiel.

Eigentlich sollte das immer genau eines sein. Prüfe ich aber noch einmal.

Bei polysom sind keine Leerzeichen bei den senkrechten Strichen…

mac-christian

Offline

Benutzeravatar


  • Wohnort: Helvetien
25  So Feb 04, 2018 0:02
Ich denke, die Syntax stimmt nicht wirklich. Und zwar für den concat - Teil.

Ich habe hier eine (englischsprachige) Anleitung gefunden. Scrolle runter zu "16. Joining multiple video parts into one" und versuche, das umzusetzen.

dino

Offline



  • Wohnort: Berlin
26  So Feb 04, 2018 16:31
Danke, Christian, werde ich versuchen.

Gruß Dino (der sich jetzt langsam an die Vorbereitungen für die Superbowl-Fete macht!)

dino

Offline



  • Wohnort: Berlin
27  Mo Feb 05, 2018 19:30
lamariposa hat geschrieben:Bei polysom sind keine Leerzeichen bei den senkrechten Strichen…

Nachdem ich die Leerzeichen rausgenommen habe, lief der Befehl ab, konnte aber nur den ersten Film identifizieren. Der zweite schien als identisch zum ersten erkannt zu werden und wurde deshalb nicht angehängt. Offensichtlich liegt das am Output von Handbreak, denn mit den ursprünglichen TS-Files funkioniert der Aufruf.

Als Zwischenlösung verbinde ich jetzt daher erst die TS-Dateien und kodiere diese anschließend mit Handbreak, bis ich was bequemeres finde.

Allen Helfern vielen Dank für die Unterstützung, jetzt habe ich erstmal einen gangbaren Weg!

Gruß Dino

MacJoerg

Offline

Benutzeravatar



  • Wohnort: Rottenburg a.N.
28  Di Feb 06, 2018 10:19
Bezüglich bequem......
Ich hatte vor Jahren mal ähnliche Probleme. Ich suchte eine Software die mit den Dateien meines damaligen
SAT-Receivers umgehen konnte (das war irgend was total ungewöhnliches). Letztendlich hab ich mir dann den Wondershare Video Converter gekauft. Kostet zwar Geld, mach aber wirklich alles. Erkennt und verarbeitet verschiedenste Formate, rechnet sie auf Wunsch am Ende in eine Datei usw.
Schau Dir das einfach mal an. Erleichtert vieles. Gerade wenn man das öfter macht lohnt es sich.
Gruß, Jörg

Rotweinfreund

Online

Benutzeravatar


  • Wohnort: Vier-Tore-Stadt
29  Di Feb 06, 2018 11:10
… gibt es manchmal auch als Giveaway.

@Ausgangsposting: ich nahm an, dass das Hauptanliegen war, ohne Neu-Codierung zu verbinden? Das leistet doch aber keines der hier genannten Tools, oder doch?

Macoldie

Offline

Benutzeravatar


  • Wohnort: Großstadt zwischen Hängen und Würgen
30  Di Feb 06, 2018 11:21
MacJoerg hat geschrieben: Letztendlich hab ich mir dann den Wondershare Video Converter gekauft. Kostet zwar Geld, mach aber wirklich alles. Erkennt und verarbeitet verschiedenste Formate, rechnet sie auf Wunsch am Ende in eine Datei usw.

Kann ich nur unterschreiben - hatte die gleichen Probleme mit Filmdateien aus einem Löwe-TV, die sich mit Wondershare wunderbar lösen ließen. Und ist auch noch ziemlich maclike :-)
Carpe diem - auch am Mac
Nächste

Zurück zu Software

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder

LESEN!